Recent posts

#1
avatar_Marius P.
Bug tracker / Re: Store bug tracker
Last post by Marius P. -
Fixed:

- Errors with empty or incomplete archive downloads
- Some orders marked paid had no download attached
#2
Quote from: HPR on Dear sir
Can we have the Demo Admin Credentials please to check the admin panel functionalities....
Thank you

I avoid doing that because my server gets a lot of hacking attempts through the admin panel (once they have a login) ::)
#3
H
Announcements / Re: PHPVibe Free Alpha 11.0.2 ...
Last post by HPR -
Dear sir
Can we have the Demo Admin Credentials please to check the admin panel functionalities....
Thank you
#4
avatar_Marius P.
Announcements / PHPVibe Free Alpha 11.0.2 rele...
Last post by Marius P. -
The fixes to the Alpha version continue, the dashboard was fixed a little, also the images manager.
I'm testing an ajax html5 history plugin, but for now, it creates issues so I've restricted it to several pages from the sidebar.

Changes in themes/main/scripts/main.js
Replace /app/functions, /moderator

Remember to always clear the cache.

Please keep testing and reporting any errors, misses, incomplete...anything wrong! ;)
Thank you!
#5
avatar_Marius P.
Bug tracker / Re: Problems during Installati...
Last post by Marius P. -
I think it's just a matter of the Alpha version missing the proper license check in the admin and reverting to the old one.
I'll add it, still have some things to add and change.

Since I no longer have more than 1 server at my disposal to test the CMS I solely rely on you guys to find the issues in the alpha.  O:-)
Thanks for your feedback so far! Really appreciate it!
#6
R
Bug tracker / Re: Problems during Installati...
Last post by raiancollyn -
Quote from: @Mario on On my side that's just a dismissable warning, not a fatal error.
What is your PHP running on?
I'll look what generates it and get back to you.

I am using PHP 8.0.25
I deleted the files and downloaded the new version to test, I also changed the PHP version to 7.4.33 to test and it seems to have worked.
It seems that the problem is the same PHP version.

You cannot view this attachment.

I noticed something else, when he accesses this screen in the image above, on the first access this screen does not appear to fill in the data, I had to refresh the page for it to appear, I do not know if it is a bug or if it is something in my installation .

Another thing I noticed is that, after installation, a message appears at the top of the page saying that the license is wrong, I found it strange because I used the PHPVibe license, I even enabled it on the site for use in that domain, see:

You cannot view this attachment.
You cannot view this attachment. 

Anyway, thanks for the help, in the meantime I'm going to test other things since I can already use it.
#7
avatar_Marius P.
Bug tracker / Store bug tracker
Last post by Marius P. -
Let me know what I've missed adding in the store phpvibe.com in order to be fully functional and easy to use for you guys.

I'm working now on the user page.
But any feedback, opinion is important!
#8
avatar_Marius P.
Bug tracker / Re: Problems during Installati...
Last post by Marius P. -
Instead of that fix just replace /setup, /storage and /app/classes
I've released 11.0.2 to fix everything I've found so far in 11.0.1
#9
avatar_Marius P.
Bug tracker / Re: Problems during Installati...
Last post by Marius P. -
Here is a fix , on ezsql class we can do a check:
Instead of lines 174-175
// Extract the column values
$j = count($this->last_result);

do this (replace them with)

// Extract the column values
$j = count((is_countable($this->last_result)?$this->last_result:[]));

PHP 7.2 or up.
#10
avatar_Marius P.
Bug tracker / Re: Problems during Installati...
Last post by Marius P. -
Let's try a hack like this

$test_db = $db->get_col("SHOW TABLES",0);

if(is_array($test_db)){

replaced with
$go - true;
if($go) {

See if the issue is generated by the tables check. It went away for me once I've had something in the db.