avatar_Marius P.

Troubleshoot problems

Started by Marius P.,

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Marius P.Topic starter

Before reinstalling the CMS (which rarely works to solve anything) please follow these simple steps :

Prepare your server settings for large file uploads and check your settings for video uploads and ffmpeg.
If the video isn't uploaded in storage/rawmedia folder something is wrong in the upload process (Server setts?), and if it doesn't convert check that /videocron.php is fired and that the settings in admin for FFMPEG are right (and tested working with the ff.php file in the tester), the Log in the admin panel will help get a clue (FFmpeg Logs in Menu).
Don't skip this, these settings can't come pre-prepared by default, you'll need to edit them in the admin, as they differ from one server setup to another.
On the Settings menu follow every setting, and save the page.
Most settings will be blank, resulting in sections not working until they are configured.

Scroll for common situations


Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

1.) Links don't work
– Make sure you upload and overwrite the .htaccess file in the PHPVibe root.
– Make sure you use Apache (else rewrite the rules for your server via a tool online) and that mod_rewrite works (AllowOverride check)
– Make sure if you upload it in a folder that you change the RewriteBase / to /your-folder-name in the main .htaccess file
Tips:
– If you can't find a .htaccess in the patch, go to your file manager and check the settings that allow you to see system, dot, and hidden files. (For Mac read this)
– Most times servers generate a blank .htaccess file, make sure you overwrite it with the one in PHPVibe's pack!
– A folder install is used! PHPVibe needs several edits in .httacess and index.php to work on a folder. Follow the comments!
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

2.)  Not grabbing video details from Youtube/trowing error

- Add your Youtube API key under Settings.
If that doesn't change anything, make sure you have no restrictions on the Google app (ip/domain).
The error_log may help with a valid response from Google (if it's not printed on the page). In the most common cases encountered clients put domain as a security referral but their server doesn't send a referral with the request.
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

3.) Missing uploaded video

Please do your server settings for file uploads as instructed in the tutorial "Server settings for large file uploads".

If after is still not working, you'll need to reduce the chucks on Plupload below your server's max limit.
In com/com_add.php find (around line 34) :

chunk_size: '5mb',
Change the 5mb value to suit your server's limits.
NOTE: Best choice is to check and configure the server properly for large file upload!
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

4.) Video is stuck on "processing"

Make sure you have:
– shell_exec(), and it's not disabled.
– Execute permissions on the videocron.php file (chmod 555 or similar).
– (most common) the right php bin path for your server under Settings -> FFMPEG Conversion
You should contact your server administrator for the right path if you have no tech knowledge.



Also, to check the conversion and see if the issue resides in the bin path you can run www.yoursite.com/videocron.php in the browser, and check the video in a few minutes.
In some cases, FFMPEG is getting killed by the system, for example when the server doesn't have enough RAM or resources for that ffmpeg operation.

Alternative solution to exec/shell_exec:
Set a system cron on your server to fire videocron.php every x minutes.
Consult your host's documentation on how to set a system cron.
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

5.) Uploaded video not working on PHPVibe; Missing converted video or/and Duration; FFMPEG debug

One of the most common issues when using PHPVibe for the first time is to see that your videos uploaded are not playable.

Do not worry!

Here is what you should do:

If you don't have ffmpeg, make sure you turn it off!

Else, if you have ffmpeg installed, and is the right version (3.0+) under Settings -> FFMPEG add you real paths for the ffmpeg command and the php bin.

If all this is correct, your new videos should work fine and the thumbnail and duration are extracted + the video is converted to a playable mp4 and shows up properly.

Note: Old videos would need to be recreated.

What happens if this doesn't fix it?

Download the PHPVibe tester https://github.com/PHPVibe/PHPVibe-Archives/tree/main/Utilities/Server%20Tester/tester and copy a file called test.avi to that folder (read the tester's instructions).

The tester will output an error, this error is most probably the answer you seek, if you don't understand it, post it in the forum for a developer to check it and guide you.

Make sure in ff.php this line:

/*
The ffmpeg command supported by your server
*/$ffmpegmd = "ffmpeg";
is edited to your ffmpeg command.
Else it will just return that the ffmpeg executable is not found.
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Go to Settings -> Logins and find this block Secret encryption salt (Only keys of sizes 16, 24 or 32 supported), make sure your random key is 16, 24 or 32 characters long.

Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Edit vibe_config.php change the mail delivery from php to smtp, and complete all the fields under mail settings.

/*
 ** Mail settings.
 */ 
$adminMail = '';
$mvm_useSMTP = false; /* Use smtp for mails? *//* true: Use smtp | false : uses's PHP's sendmail() function */$mvm_host = 'mail.domain.com';  /* Main SMTP server */$mvm_user = ''; /* SMTP username */$mvm_pass = 'mail pass'; /* SMTP password */$mvm_secure = 'tls'; /* Enable TLS encryption, `ssl` also accepted */$mvm_port = '';  /* TCP port to connect to*/
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Pages returning 404 from time to time
Weird blockages on upload, sessions being killed? Disable mod_Security on the account.
Also make sure that you don't use :name in permalinks if you use characters like arabic or chinese, korean, etc.
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Date and time

Set the timezone to yours in vibe_config.php. You can get your timezone from PHP : List of Supported Timezones. https://www.php.net/manual/en/timezones.php


/** Timezone (set your own) **/date_default_timezone_set('Europe/Bucharest');
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Multiple same videos on the carousel


The carousel is set to infinite scroll, once you have more than 6 videos you won't have this problem.

Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Failed to remove cache folder warning

This isn't an actual error, and you shouldn't worry about it. Once this happens individual files are removed.
In most common cases removing folders with php will fail, and the cache clear will move to "plan B".
Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

The video not showing on the website but appears under "Unpublished"

Head to Settings -> Uploading and change the Uploaded video state.
You'll need to publish manually the previously saved videos as this setting change will only affect post-save imports.

Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Marius P.Topic starter

Views/Likes/Other numbers are not updating

PHPVibe has 3 layers of caching, the full cache (frozen stage) should not be used for fresh websites.
In vibe_config.php you can switch it off.

Happy with my help? Buy me a coffee.
Please, always use the search before opening a new topic! We're all here on our (limited) free time! Make sure you help yourself too!
  •  

Similar topics (1)